PHPStorm在Mac系统提示您需要安装旧 Java SE 6 运行环境的解决办法

PHPStorm在Mac系统提示您需要安装旧 Java SE 6 运行环境的解决办法

因为需要开发某些东西的缘故,给我的Mac系统安装的是jdk 1.7 版本,但是等我下载phpstrom这货的时候,竟然提示

Mac系统


您需要安装旧 Java SE 6 运行环境才能打开PHPStorm。

提示这个错误,主要是缺少JAVA SE6的环境,可以通过:

1)下载JAVA SDK6(http://support.apple.com/kb/DL1572?viewlocale=zh_CN&locale=en_US),但是我我已经安装了java SDK 7了,不想再折腾了。


其他,phpstrom也为我们考虑到了,如果是高版本的,也有办法。

如果你已经安装了其他版本的JAVA SDK,可以在终端下进入phpstorm.app目录,然后

找到info.plist,修改JVMVersion这个key对应的value为你系统安装好的JDK版本即可

<key>JVMVersion</key>
      <string>1.7*</string>

这样就OK了,


最后送上phpstrom的注册码,有钱的话,还是买一个吧,这么强大的工具,需要更多的人支持。



Learn Programming


===== LICENSE BEGIN =====
63758-12042010
00000Ryqh0NCC73lpRm!XVcxFChJ2g
TUR2lZtlLXrPLbQ66Gs8MHs51RvF2y
agoDlzne08Zm8VXbts1UMKE!EW4v8G
===== LICENSE END =====

关键词: javasdk , phpstrom

上一篇: 教你如何提取iPhone应用ipa包中的图片资源文件
下一篇: 安卓开发之设置webview的浏览器标识(User-Agent)

访客评论
目前还没有人评论,您发表点看法?
发表评论

评论内容 (必填):